Changes between Initial Version and Version 1 of NAMING_CONVENTIONS
- Timestamp:
- 09/16/08 17:07:13 (17 years ago)
Legend:
- Unmodified
- Added
- Removed
- Modified
-
NAMING_CONVENTIONS
v1 v1 1 === Avoid non desciptive names === 2 3 A name should be clear enough to suggest what the thing is given the local context. For example: 4 <pre> 5 private static final int FRAME_CORRECTION_POSITION = 20; 6 </pre> 7 is not clear in the context of the class Frame. It may be more clear in the context of the frameDropped() method, but here it is not. A better name would be 8 <pre> 9 private static final int FRAME_DROP_OFFSET = 20; 10 </pre> 11 12 ==== Avoid inaccurate names ====